Repetier Firmware Now Runs on Printrboard

I spent this past weekend porting Repetier-Firmware to Printrboard and Teensyduino. It took me a while to get it working properly, because the code intermixes calls to fastio and Arduino, and the pin definitions in fastio.h were different from the Teensyduino Arduino library. It is now working pretty well, so Printrboard and Teensylu users now have yet another option for RepRap firmware. I’ve already submitted my changes to Repetier, and he’s merged them into his code. Download it here:

In case you haven’t tried it, Repetier also has an interesting host program, Repetier-Host, which works with other firmwares as well as Repetier-Firmware.

7 thoughts on “Repetier Firmware Now Runs on Printrboard”

  1. I’ve tried to compile repetier for my printrboard, but it seems that it needs WProgram.h and pins_arduino.h from some other source. I know repetier itself comes with these in its boards file, but none are listed as specifically being for printrboard. Should I use one of those, or some other set of files?

  2. Hey,

    I have been trying for basically two days to get Repetier (or Sprinter) installed on my Printrboard Rev D. to run a Prusa v2. I have a correctly configured version of Arduino with the Teensyduino add ons and I also installed the teensyduino serial driver so it connects to my board. My problem has been that the code successfuly complies and then will sit in the ‘Uploading to I/O state’ for hours and will not load onto my board. Any idea what could be causing this? I am pretty sure I am uploading it into the bootloader state (I followed the directions on the RepRap wiki printrboard page) I guess the one other thing is that I am trying to do this via the USB port. Do you think I would have better results getting a USBtiny programmer?


    1. I think on the RevD, you need to put the jumper in, unlike previous revs, where you take it out, before pressing the reset button.
      Yes, a USBTinyISP will also work, if you prefer.

      1. I tried doing that but my computer doesn’t recognize the board when it is reset when the jumper is in, but it does recognize it when I do it the ‘old way’ where the jumper is off when I reset it. Is this a driver problem?

        1. Sounds like either the driver is missing, or the bootloader is missing. If the CDC bootloader you have installed is the LUFA CDC bootloader that I used, you can use the INF file in, linked in this article: You should really contact the vendor from whom you purchased the board and asked for help. As you can see from the linked article, there are 3 different bootloaders that can be installed, and even worse, whoever installed it could have used Teensy’s USB VID/PID, making it need Teensy’s INF file instead. If all else fails, you can either 1) program Marlin into it with USBTinyISP directly, or 2) Install my CDC bootloader with the USBTinyISP, and then use that. The advantage of the CDC bootloader over direct programming with the USBTinyISP is the download speed.

          1. Okay thanks. Neither of those drivers are working so I’ll spring for a USBTinyISP programmer and try to install that way or install a new bootloader. Thanks so much.

Leave a Reply